Announcement

Collapse
No announcement yet.

Fix: Rappelz wont start! (after i closed it)

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Fix: Rappelz wont start! (after i closed it)

    So sometimes when you quit Rappelz, and want to start it again (could be after 5 mins or 5hrs or a day even) it wont start!

    Game Guard throws an error 115 saying game guard is already running. (see pic for example)
    Well the usual solution is to restart the PC.
    But what if you got things going on you don't wanna close (and wanna take the risk that game guard?
    Here's the solution:

    Run an elevated command prompt (means run cmd as admin), click here if you don't know how to do that.
    In the command prompt type tasklist and enter (see pic for example).
    Then look for the line with SFrame.exe (see pic).
    Then notice the PID (6052 in the example pic; PID is Process ID, it will change each time you start the game.)
    Then type taskkill /f /pid 6052 and press enter (but change 6052 to your SFrame.exe PID)
    That will end the Game Guard process, and you can restart rappelz!



    Or:

    Type: taskkill /f /im SFrame.exe

    That's it!!
    ================================================== ===========
    Below this line are instructions for making file that will do it automatically for you.
    After following the steps below you can just double-click the file and it will kill sframe, easy!

    I myself use a batch file, here is how to make your own:



    1: Start notepad (Win+R, type notepad, enter/ok)
    2: type this in notepad:
    ECHO OFF
    taskkill /f /im SFrame.exe
    3: save (Ctrl+S)
    4: change "Save as type:" to "All Files (*.*)"
    5: set the name to whatever.bat, the important part is that it ends in .bat, mine is called Kill_SFrame.bat
    6: that's it, you now created a batch file, put it in your start bar, start menu, desktop, or where ever is easy to access (mine is in the start menu under the rappelz icon)
    7: double click that file any time you want to kill SFrame.exe, which will also end game guard (dont run while game is open!! lol)

    My favorite quote from forum: I happen to be a certified math genus in multiple relevant fields, I could tell you but i doubt you will understand them. no really normal people are like what the hell is that even a few fields of greater intelligence don't understand them well. LOL!
    My toons: Slayer - VoidMage - Mercenary - Magus - Templar - Berserker

  • #2
    On the basis that I probably won't remember this for when I actually need to use it next, can this be stickied?
    No seriously, this is a good candidate, unlike some of your past nonsensical stickies.
    Also, google.co.jp? Neat.

    Comment


    • Athyra
      Athyra commented
      Editing a comment
      ty

    • Mochatroid
      Mochatroid commented
      Editing a comment
      Agreed, ty.

  • #3
    Thanks so much!
    You have no idea how many times I have had to restart my PC against my will to solve this.
    캔트나를보고
    YouTube
    Statbuilder - Working on it

    Comment


    • Athyra
      Athyra commented
      Editing a comment
      yeah i have been doing this for ages and only just realized that others may not realize it lol..

  • #4
    I'm afraid making it a sticky in the general section is not an option, but I moved it to help! and pinned it there - hope that's a viable solution.



    [Rappelz] Critical Probability (base attacks only)
    Moderated Guild Website

    Comment


    • Athyra
      Athyra commented
      Editing a comment
      if it helps people - it is viable!

  • #5
    This seems really useful. I have thought for ages that my pc takes a very long time to finish running GameGuard, which is an immense irritation if I crash, or simply want to restart because I know otherwise I will crash soon.

    Comment


    • Athyra
      Athyra commented
      Editing a comment
      oh the worst is when you need to restart and you dont force-close gameguard, it takes foreeeeever to log off / shutdown!

      i have actually made a batch file with the command lol

    • Noire
      Noire commented
      Editing a comment
      I wonder if that's why sometimes my computers can be logging off for quite literally hours.....

  • #6
    I got a few more TYs (here and in game) than I expected for this thread lol.
    So, I decided to share how I do this myself, I use a batch file, here is how to do it:



    1: Start notepad (Win+R, type notepad, enter/ok)
    2: type this in notepad:
    ECHO OFF
    taskkill /f /im SFrame.exe
    3: save (Ctrl+S)
    4: change "Save as type:" to "All Files (*.*)"
    5: set the name to whatever.bat, the important part is that it ends in .bat, mine is called Kill_SFrame.bat
    6: that's it, you now created a batch file, put it in your start bar, start menu, desktop, or where ever is easy to access (mine is in the start menu under the rappelz icon)
    7: double click that file any time you want to kill SFrame.exe, which will also end game guard (dont run while game is open!! lol)

    My favorite quote from forum: I happen to be a certified math genus in multiple relevant fields, I could tell you but i doubt you will understand them. no really normal people are like what the hell is that even a few fields of greater intelligence don't understand them well. LOL!
    My toons: Slayer - VoidMage - Mercenary - Magus - Templar - Berserker

    Comment


    • (MOD)Alexander
      (MOD)Alexander commented
      Editing a comment
      Mine is fancier (and hunts leftover gameguard-remains that somehow managed to survive the sframe.exe, too) ;-)

      Code:
      @taskkill /f /im SFrame.exe
      @taskkill /f /im GameMon.des
      @taskkill /f /im GameMon64.des
      @echo Rappelz-Client and remaining Gameguard instances killed!
      @pause

    • Athyra
      Athyra commented
      Editing a comment
      i havent yet experienced a situation where killing sframe.exe didn't also end the gamemons
      but if that ever did happen to me i would also add those 2 other lines
      i also like echo off, no need for the window to stay open, but if you wanna see the results the pause is always good!

    • (MOD)Alexander
      (MOD)Alexander commented
      Editing a comment
      Well the @ in front of the commands does the same thing as using echo off ;-) that is mostly a matter of personal preference :-D and ya, I like to see if the script actually ran or I clicked too slow or something and it didn't, so the pause makes sure the window stays around long enough

      And it seems on one of my slaveboxes for some reason the GameMon.des survives longer than the SFrame.exe - no idea why, but just had it happen again.

      The weird thing is that it's a 64 bit system, so one would think the GameMon64.des would be the one outlasting things, but no...

  • #7
    I have been trying to connect to the server for 3 days, and I keep getting an error code 10060 or a green screen saying cannot connect to the index server! I did manage to go on yesterday for a short time until about 1:00AM EST and thought the problem was fixed but today I get the same error and green screen when I try to launch. I uninstalled the game and re-installed it again and still the same problem occurs! PLEASE HELP!

    Comment


    • #8
      Thank you Athyra for your in depth reply! However, this is not what I was asking... My system used to be able to connect to the game in days leading up to this problem, but since Thursday December 8th, all I have been able to get 95% of the time is the launch window and a long delay with the green screen stating "Cannot connect to update server(10)" Other times the game seems to launch, up to the sign-up screen. When I enter my username and password and submit it, I get a white window box stating: "Cannot connect, error 10060". I have tried all your suggestions and none of them make any difference! :-(

      Comment


      • #9
        I forgot to mention; last night I was able to log in for about 5 minutes, and to make changes to my screen resolution in options since I had re-downloaded the game and it was set to default mode. It worked OK, and when I started playing I got disconnected again with the same old: "cannot connect to the index server; error 10060" :-( If you ask me the problem is at the Webzen end of the matter not my system! I wrote to them seeking help, but they basically brushed me off reffering me back to the forums... Heaven forbid I should take a little of their time to investigate the issue! Some customer service, blah!

        Comment


        • #10
          I have similar problema. Pls can help me. Yesterday I close the game and now when I try to start agen every time I have some erorr. Restarting system, updating etc. but problem isnt resolved pls help me.http://prntscr.com/ifxwws
          Last edited by Saik2tt; 17-02-18, 06:48 PM.

          Comment

          Working...
          X